Fix Error: Čini se da u vašoj PHP instalaciji nedostaje MySQL ekstenzija koju zahtijeva WordPress

"Čini se da u vašoj PHP instalaciji nedostaje MySQL ekstenzija koju zahtijeva WordPress”Je li pogreška s kojom se susreću mnogi vlasnici blogova i web stranica WordPress.
To nije razlog za zabrinutost. Nedostatak MySQL ekstenzije iz PHP-a tipično je za operativne sustave instalirane od nule, VPS-a ili namjenske poslužitelje gdje PHP proširenja nisu bila dio instalacijskog paketa. Ovaj je problem prisutan na oboje Ubuntu i CentOS. U ovom se scenariju problem rješava vrlo jednostavno pomoću PHP ažuriranja i instalacije modula "PHP-mysql".
Ažurirajte PHP i instalirajte MySQL ekstenziju na Ubuntu

apt-get update
apt-get install php-mysql

Ažurirajte PHP i instalirajte MySQL ekstenziju na CentOS

yum update
yum install php70w-mysql

Nakon ovog koraka, ponovno pokrenite Apache uslugu ili Nginx.

Također sam naišao na scenarij u kojem, iako proširenje MySQL postoji u PHP-u, blog stvoren na WordPressu prikazao je pogrešku "Čini se da vašoj PHP instalaciji nedostaje proširenje MySQL koje zahtijeva WordPress". Do pogreške se najčešće dolazi prilikom instaliranja WordPressa. Međutim, ovaj se put pojavio na blogu koji je aktivan već nekoliko godina.
U ovoj situaciji otkrio sam da problem nije u PHP modulima, već u vrlo staroj verziji WordPressa, koja više nije kompatibilna na PHP 7.4.4RC1. Jednostavna nadogradnja WordPressa na najnoviju verziju riješila je pogrešku.

Fix Error: Čini se da u vašoj PHP instalaciji nedostaje MySQL ekstenzija koju zahtijeva WordPress

O autoru

potajno

Zaljubljen u sve gadgete i IT, pišem sa zadovoljstvom u stealthusettings.com od 2006. godine i volim s vama otkriti nove stvari o računalima i operativnim sustavima macOS, Linux, Windows, iOS i Android.

Ostavite komentar